WebFX WebBoard
Message Thread:
View All Messages
Back to WebFX
 richedit getXHTML bug, andot, October 25, 2002
     Re:richedit getXHTML bug, Erik Arvidsson, October 25, 2002
         Re:richedit getXHTML bug, andot, October 26, 2002
             Re:richedit getXHTML bug, Erik Arvidsson, October 27, 2002
                 Re:richedit getXHTML bug , andot, October 28, 2002
                     Re:richedit getXHTML bug , Erik Arvidsson, October 28, 2002
                 Re:richedit getXHTML bug, andot, October 28, 2002
             Re:richedit getXHTML bug, Erik Arvidsson, October 27, 2002
                 Re:richedit getXHTML bug, andot, October 28, 2002

Subject: Re:richedit getXHTML bug From: andot Date: October 28, 2002

Thank for your help. I find I make mistake. You are right. To replace '&', '<', '>' and '"' with "&amp;", "&lt;", "&gt;" and "&quot;" can also work well in script if the script write correct. Now I think your old code is also perfect, you needn't change it any more. It is not a bug, only my mistake. I sorry to bring you so much trouble.

From: Erik Arvidsson
Sent: October 28, 2002
Subject: Re:richedit getXHTML bug

XML attributes can not contain '<' or '&' (unless & is part of an entity reference). Period.

See http://www.w3.org/TR/REC-xml#NT-AttValue

erik





Reply
Name: 
Email: 
Subject: 

Enter your reply to this message below. HTML tags are not supported but words that start with http://, ftp:// or mailto: are converted to links.


View All Messages
Back to WebFX