WebFX WebBoard
Message Thread:
View All Messages
Back to WebFX
 menu4: initial menu/submenu size sometimes incorrect, Jason Bernstein, July 24, 2002
         Re:menu4: initial menu/submenu size sometimes incorrect , Erik Arvidsson, August 2, 2002
             Re:menu4: initial menu/submenu size sometimes incorrect , Jason Bernstein, August 2, 2002
                 Re:menu4: initial menu/submenu size sometimes incorrect , Erik Arvidsson, August 3, 2002

Subject: Re:menu4: initial menu/submenu size sometimes incorrect From: Erik Arvidsson Date: August 3, 2002

I'll take a look at this. Thanks for the info.

erik

From: Jason Bernstein
Sent: August 3, 2002
Subject: Re:menu4: initial menu/submenu size sometimes incorrect

in Menu.prototype.updateSizeCache, after

var d = this.getMeasureDocument();

it is possible that d.readyState != 'complete'

I have put in an alert here and seen both "interactive" and "loading"

To reproduce (completely unreliably), try building a menu with submenus each time you bring up the context menu. This way it will rebuild it and you don't need to reload the page each time.

I can send screenshots so you can see, but I don't know how to post them to this board. I don't have a public website I can put it on. What it ends up looking like, though, is 1) the menu is complete, with a black line around it, but then there's extra white space at the bottom, 2) the menu is incomplete, where the right border is not shown, or 3) the menu is horribly incomplete, where it is only about 10 pixels wide, with extra white space under the laste menu item.

-jas

-jas

From: Erik Arvidsson
Sent: August 2, 2002
Subject: Re:menu4: initial menu/submenu size sometimes incorrect

If the width/height is incorrect the left/top will be incorrect in a few cases because width/height are taken into account when the position is calculated.

I would really appreciate if anyone that get these size errors could tell me how to reproduce them since I've never seen them. This might help me to locate what is going wrong and help me fix this.

erik

From: Jason Bernstein
Sent: August 1, 2002
Subject: Re:menu4: initial menu/submenu size sometimes incorrect

I've also noticed that when the width and height are incorrect, the left is also incorrect.

When the sizes are off, the submenus appear on TOP of the arrows instead of slightly to the right. I'm digging through the code to see if I can figure out why.

-jas

From: Jason Bernstein
Sent: July 24, 2002
Subject: Re:menu4: initial menu/submenu size sometimes incorrect

I've noticed that on a semi-regular basis, the menus will appear the wrong size. When displayed correctly, the menu is 203 x 234. Sometimes it will appear about 10 x 260. Sometimes 203 x 260. Rarely it will be too thin (like 190x260).

I can't reproduce it reliably - it is probably a timing issue. I'm not sure if its because the entire page, including the stylesheet, hasn't finished loading at the point that the measurement is taken, but the incorrect size is definitely a problem. It happens both when I have and don't have icons, and when I have or don't have separators.








Reply
Name: 
Email: 
Subject: 

Enter your reply to this message below. HTML tags are not supported but words that start with http://, ftp:// or mailto: are converted to links.


View All Messages
Back to WebFX