WebFX WebBoard
Message Thread:
View All Messages
Back to WebFX
 UI: XTree XLoadTree container in container bug, Arnas, March 25, 2002
     Re:UI: XTree XLoadTree container in container bug, Erik Arvidsson, March 25, 2002
         Fix for XTree, Laurent Ains, February 22, 2004

Subject: Re:UI: XTree XLoadTree container in container bug From: Erik Arvidsson Date: March 25, 2002

This must be a bug in xTree because XLoadTree does not handle the rendering. Most likely this happens because the removal of the "Loading..." item does not restore the state correctly. Hopefully Emil can help us out here to figure out how to solve this.

erik

From: Arnas
Sent: March 25, 2002
Subject: Re:UI: XTree XLoadTree container in container bug

Hi all,
I started to use XTree very cool widget. However I've noticed on little bug.
When I use it in the way posted below I get extra I line below plus icon in level 1 as it were some extra element in same level. however it looks corectly in levels below (2 and 3). and it sure looks fine if i add extra element (5) in level 1 :))

xml:
<tree>
  <tree text="1" action="javascript:alert(1)">
   <tree text="2" action="javascript:alert(2)"
>
     <tree text="3" action="javascript:alert(3)
">
       <tree text="4" action="javascript:alert(4)
"/>
     </tree
>
   </tree
>
  </tree
>
  <!--  <tree text="5" action="javascript:alert(5)"/>  -->
</tree>

script:
<script type="text/javascript">
  var tree = new WebFXLoadTree("root", "1.xml");
  document.write(tree);
</script>





Reply
Name: 
Email: 
Subject: 

Enter your reply to this message below. HTML tags are not supported but words that start with http://, ftp:// or mailto: are converted to links.


View All Messages
Back to WebFX